Breaking News
Loading...
05 December 2011

Load Balancing Dua ISP dengan Mikrotik

10:43 AM

Sebelum membahas setting load balancing, ada baiknya kita lihat pengertian tentang load balancing. Load balancing bisa dikatakan sebagai teknik menyeimbangkan beban bandwidth ke dua atau lebih jaringan internet dari ISP yang sama atau berbeda,dan digunakan untuk sebuah jaringan LAN. Artinya, dua jalur internet digabung ke dalam sebuah router, lalu disalurkan ke jaringan LAN dengan tujuan memaksimalkan kinerja bandwidth LAN.

Saya anggap, kita telah memiliki dua koneksi internet, misal modem1 dan modem2, juga telah memiliki sebuah router mikrotik. Pastikan bahwa PC/router mikrotik memiliki 3 ether. Kebutuhannya adalah, ether untuk modem1, ether untuk modem2 dan ether ke client.

Agar mudah memudahkan langkah settingan, sebaiknya kita ubah IP modem1 dan modem2 seperti berikut ini: modem1: 192.168.1.1/24,modem2:192.168.2.1/24. IP mikrotik untuk interface client: 192.168.0.1/24. Semua IP ini bisa disetting sesuai dengan kebutuhan.

Setting di winbox interface sebagai: ether0=client, ether1=modem1, ether2=modem2.

Kita masuk ke mikrotik, melalui new terminal, kita ikuti langkah berikut:
Setting IP Addres
/ ip address add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=client
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=modem1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=modem2

IP Route
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1,192.168.2.1 check-gateway=ping
Setting Firewall: NAT dan Mangle
/ip firewall nat
add chain=srcnat out-interface=modem1 action=masquerade
add chain=srcnat out-interface=modem2 action=masquerade
/ ip firewall mangle
add chain=input in-interface=modem1 action=mark-connection new-connection-mark=modem1_conn
add chain=input in-interface=modem2 action=mark-connection new-connection-mark=modem2_conn
add chain=output connection-mark=modem1_conn action=mark-routing new-routing-mark=to_modem1
add chain=output connection-mark=modem2_conn action=mark-routing new-routing-mark=to_modem2

Routing ke mangle
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_modem1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_modem2

Bagi yang berhasil setting sampai di sini, berarti load balancing sudah berhasil. Oops, tapi tunggu dulu, biasanya pada IP route, akan tampak IP yang berwarna biru, yang biasanya membingungkan, apakah settingan kita gagal atau bagaimana. Tapi jangan khawatir, biasanya ini akan normal setelah jaringan kita terhubung secara benar ke PC router mikrotik yang kita install. Jika masih biru, artinya koneksi dari modem belum terhubung ke router mikrotik.

0 komentar:

Post a Comment

 
Toggle Footer