Breaking News
Loading...
02 January 2012

TIPS MENGATASI BROWSING LEMOT PADA LOAD BALANCING

10:19 AM
TIPS MENGATASI BROWSING LEMOT PADA LOAD BALANCING
diterapkan pada 2 ISP berbeda Provider dan Bandwith
Speedy 1024 VS ISP X 256Kbps 1:8

konsepnya sama dengan load balancing biasa Simple Load Balancing + DNS Resolver + Secret Fiture
hanya di sini kita akali menambah satu ISP palsu untuk menyeimbangkan akses

langsung praktek ja.. biar ga bingung heheheh

1. Pake WinBox masuk ke -> IP -> Address
-> klik [+] -> isikan Address : 192.168.1.1/24
Network : 192.168.1.0
Broadcast : 192.168.1.255 -> Konfigurasi LAN ( Local)
Interface : Ether1
-> klik [+] -> isikan Address : 192.168.2.2/24
Network : 192.168.2.0
Broadcast : 192.168.2.255 -> Konfigurasi WAN 1 (Speedy)
Interface : Ether2
-> klik [+] -> isikan Address : 192.168.3.2/24
Network : 192.168.3.0
Broadcast : 192.168.3.255 -> Konfigurasi WAN 2 (ISP)
Interface : Ether3


2. Buat Mangle. Pake WinBox pilih -> New Terminal

Paste kan Kode Berikut
/ip firewall mangle [lalu enter]
add chain=prerouting in-interface="ether1" connection-state=new nth=2,3,0 action=mark-connection new-connection-mark=lb_1 passthrough=yes comment="LB Client" disabled=no
add chain=prerouting in-interface="ether1" connection-mark=lb_1 action=mark-routing new-routing-mark=route_lb_1 passthrough=no comment="" disabled=no
add chain=prerouting in-interface="ether1" connection-state=new nth=2,3,1 action=mark-connection new-connection-mark=lb_2 passthrough=yes comment="" disabled=no
add chain=prerouting in-interface="ether1" connection-mark=lb_2 action=mark-routing new-routing-mark=route_lb_2 passthrough=no comment="" disabled=no
add chain=prerouting in-interface="ether1" connection-state=new nth=2,3,2 action=mark-connection new-connection-mark=lb_3 passthrough=yes comment="" disabled=no
add chain=prerouting in-interface="ether1" connection-mark=lb_3 action=mark-routing new-routing-mark=route_lb_3 passthrough=no comment="" disabled=no

3. Buat Nat. Pake WinBox pilih -> New Terminal

Lagi Lagi Paste kan [ maklum sebagai newbie males nulis ]
/ ip firewall nat
add chain=srcnat out-interface="ether3" action=masquerade comment="" disabled=no
add chain=srcnat out-interface="ether2" action=masquerade comment="" disabled=no

4. Buat Route. Pake WinBox pilih -> New Terminal
Copy Paste Lagi Bosssss
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=route_lb_1 comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=10 routing-mark=route_lb_2 comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark=route_lb_3 comment="" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 comment="default routing connection" disabled=no

Sampai Disini Load Balancing Telah Beres...

jadi hanya Dua ISP di buat 3 Round Load Balancing + 1 Default Gateway

breAK dlu abis ini gw lanjutin... save as dlu




untuk menyempurnakan Aksi Tipu Tipu tadi.. wajib kita tambahkan settingan ini..

1. aktifkan Web Proxy

jangan tanya caranya... klo ga tau kebangeten... heheh
di sini saya contohkan dengan menggunakan port:3128 ( standar bangeeeet )

2. buat NAT Rulenya
pake winbox > ip > firewall > NAT
[+] (add)

chain : dstnat
protocol : (6) tcp
dst.port : 80
in. interface : ether1 (lan localnya)
connection mark : [!] lb_2 <--- tanda [!] di check ( artinya selain )
Routing mark :[!] route_lb_2
submenu > Action
action : redirect
to ports : 3128 ( port WebProxy )

eiiiitt.... ada yang ketinggalan..

Mencegah YM dan MIRC Diskonek saat Load Balancing
pada mangle pembuatan connection mark yang telah dibuat di Load Balancing tadi [ bukalah pakai WinBox -> Ip -> Firewall -> mangle ] pada kolom protocol tambahkan 6(TCP) dan dst port 80 ( jangan lupa aplikasikan pada ketiga mangle tersebut baik lb_1 lb_2 maupaun lb_3 )
apa fungsinya ??
fungsinya semua koneksi selain HTTP (80) akan di routing menggunakan default routing conncetion alias satu IP Route jadi ndak bolak balik drop.

wis dijamin sip tuh.. load balancing + Web Proxynya..

0 komentar:

Post a Comment

 
Toggle Footer