Breaking News
Loading...
16 February 2012

SISTEM KERJA dan LANGKAH-LANGKAH SETTING TRANSPARENT PROXY SERVER MIKROTIK

SISTEM KERJA PROXY SERVER
Asumsinya ketika client1 mengakses website A maka proses yang terjadi adalah client1 meminta/request ke web server yang mempunyai website A tersebut. Ketika client2 atau yang lain mengakses website yang sama (website A) maka proses client tersebut akan mengulang kembali proses meminta/request ke web server tersebut. Seandainya ada banyak client lain yang mengakses website yang sama (website A) maka proses yang sama akan dilakukan lagi. nah inilah yang membuat akses terasa lambat.
Disinilah peran sebuah Proxy sangat dibutuhkan untuk mempercepat akses website. Suatu halaman website yang pernah dikunjungi oleh client akan disimpan (cache) di server proxy. Ketika ada client yang meminta/request suatu website maka client tidak langsung request ke webserver. client akan mencari website yang direquest-nya ke proxy dulu, kalo ada maka proxy akan menjawab request tersebut dan memberikannya ke client, jika website yang dicari tidak ditemukan di simpanan/Cache proxy barulah proxy server request website tersebut ke webserver dituju.KONFIGURASI PADA MIKROTIK SERVER
Asumsi
IP Modem =  192.168.1.1/30
IP Ether1   =  192.168.1.2/30 –>ke inet
IP Ether2   =  192.168.20.1/24 –> ke LAN
  • Setting Interface LAN card
    /interface
    set ether1 name=inet
    set ether2 name=lan keterangan:
    ether1 dan ether2 diganti nama interface) tujuannya biar mudah di ingat gak ada pengSetting IP address
    /ip address
    add address=192.168.1.2/30 interface=inet
    add address=192.168.20.1/24 interface=lan
  • Setting Gateway
    /ip route
    /add gateway=192.168.1.1
  • Setting DNS
    /ip dns
    set primary-dns=202.134.1.10
    set secondary-dns=203.130.196.155
    set allow-remote-requests=yesKeterangan :
    DNS digunakan untuk menerjemahkan alamat IP ke domain (****.com, ****.net, dll) atau sebaliknya, ada beberapa DNS untuk speedy pilih yang latency-nya kecil dengan nge-ping agar akses ke dns-nya agak cepat dikit.
  • Setting NAT
    /ip firewall nat
    add chain=srcnat action=masquerade out-interface=inetketerangan :
    Network Address Translation (NAT) fasilitas router untuk meneruskan paket dari ip asal dan atau ke ip tujuan dan merupakan standart internet yang mengizinkan komputer host dapat berkomunikasi dengan jaringan luar menggunakan ip address public.
  • Setting web Proxy (transparent)
    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128
    hostname=aamproxy transparent-proxy=yes
    parent-proxy=0.0.0.0:0 cache-administrator=globalnet_001@yahoo.com
    max-object-size=131072KiB cache-drive=system max-cache-size=unlimited \
    max-ram-cache-size=unlimited
    Keterangan :
    settingan web proxy yang lain menggunakan default bawaan mikrotik.
    hostname=hostname dns atau ip address web proxy
    cache-administrator=email admin yang bisa dihubungi ketika proxy error, yang akan ditampilkan pada browser client ketika proxy error.
  • Setting redirect ke proxy
    /ip firewall nat
    add chain=dstnat protocol=tcp dst-port=80 action=redirect to-port=3128
    add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-port=3128
    keterangan :
    Redirect digunakan untuk membelokkan/memaksa koneksi port 80 (www/web) dari client ke port 3128 default-nya web proxy mikrotik, jadi semua request client yang menggunakan port 80/8080 (www/web) akan di belokkan ke web proxy mikrotik.
  • Memonitor web proxy
    /ip web-proxy monitor

setting web-proxy mikrotik 2.9.27


Proxy server merupakan program yang dapat mempercepat akses ke suatu web
yang sudah diakses oleh komputer lain, karena sudah di simpan didalam
caching server.Transparent proxy menguntungkan dalam management client,
karena system administrator tidak perlu lagi melakukan setup proxy di
setiap browser komputer client karena redirection dilakukan otomatis di sisi
server.

Bentuk perintah konfigurasi :
a. Setting web proxy :
- ip proxy set enable=yes
port={ port yang mau digunakan }
maximal-client-connections=1000
maximal-server-connections=1000
- ip proxy direct add src-address={ network yang akan di
NAT} action=allow
- ip web-proxy set parent-proxy={proxy parent/optional}
hostname={ nama host untuk proxy/optional}
port={port yang mau digunakan}
src-address={ address yang akan digunakan untuk koneksi
ke parent proxy/default 0.0.0.0}
transparent-proxy=yes
max-object-size={ ukuran maximal file yang akan disimpan
sebagai cache/default 4096 in Kilobytes}
max-cache-size= { ukuran maximal hardisk yang akan
dipakai sebagai penyimpan file cache/unlimited
| none | 12 in megabytes}
cache-administrator={ email administrator yang akan digunakan
apabila proxy error, status akan dikirim
ke email tersebut}
enable==yes
Contoh konfigurasi
——————-
a. Web proxy setting
/ ip web-proxy
set enabled=yes src-address=0.0.0.0 port=8080
hostname=”proxy.routerku.co.id” transparent-proxy=yes
parent-proxy=0.0.0.0:0 cache-administrator=”support@routerku.co.id”
max-object-size=131072KiB cache-drive=system max-cache-size=unlimited
max-ram-cache-size=unlimited
Nat Redirect, perlu ditambahkan yaitu rule REDIRECTING untuk membelokkan
traffic HTTP menuju ke WEB-PROXY.
b. Setting firewall untuk Transparant Proxy
Bentuk perintah konfigurasi :
ip firewall nat add chain=dstnat
protocol=tcp
dst-port=80
action=redirect
to-ports={ port proxy }
Perintahnya:
——————————————————————————–
/ ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080
comment=”” disabled=no
add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080
comment=”” disabled=no
add chain=dstnat protocol=tcp dst-port=8000 action=redirect to-ports=8080
——————————————————————————–
perintah diatas dimaksudkan, agar semua trafik yang menuju Port 80,3128,8000
dibelokkan menuju port 8080 yaitu portnya Web-Proxy.
CATATAN:
Perintah
/ip web-proxy print { untuk melihat hasil konfigurasi web-proxy}
/ip web-proxy monitor { untuk monitoring kerja web-proxy}
sumber asli http://setiawansaja.blogspot.com/2009/02/setting-web-proxy-mikrotik-2927.html

0 komentar:

Post a Comment

 
Toggle Footer