Breaking News
Loading...
02 May 2012

Cara Install Proxy Squid Lusca di Ubuntu Server 10.10

Persiapan:
- Download Ubuntu Server 10.10, PUTTY, WINSCP
- Cara Install Ubuntu Server 10.10 dan cara partisi hardisk

Saya asumsikan anda sudah berhasil menginstal ubuntu dan sudah dapat melakukan ping ke www.google.com dari ubuntu server.

Langkah-langkah:
1. Buka PUTTY dan masuk ke ubuntu server.
2. Ketik passwd dan isikan password untuk root.
3. Ketik sudo su dan masukkan password root tadi.
4. Copy-paste satu baris-satu baris perintah di bawah ini di PUTTY:
  • apt-get update
  • apt-get upgrade -y 
  • apt-get dist-upgrade -y
  •  apt-get install squid -y 
  • apt-get install squid squidclient squid-cgi -y 
  • apt-get install gcc -y 
  • apt-get install build-essential -y 
  • apt-get install sharutils -y 
  • apt-get install ccze -y 
  • apt-get install libzip-dev -y 
  • apt-get install automake1.9 -y 
  • wget http://proxy-ku.googlecode.com/files/LUSCA_FMI.tar.gz 
  • tar xzvf LUSCA_FMI.tar.gz
  • cd LUSCA_FMI
  • make distclean
 5. Copy-paste perintah di bawah ini di PUTTY untuk melaukan compile:.
./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files --enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536 
6. Selanjutnya copy-paste perintah di bawah ini di PUTTY untuk melaukan instalasi compile LUSCA.
  • make
  • make install 
7. Download squid.conf, storeurl.pl dan squid
    DISINI 
8. Jalankan WINSCP dan masuk ke ubuntu server dengan user root dan password yang dibuat tadi.
  • copy file squid ke folder /etc/init.d
  • copy file squid.conf dan storeurl.pl ke folder /etc/squid
9. Selanjutnya copy-paste perintah di bawah ini di PUTTY.
  • chmod +x /etc/init.d/squid
  • /etc/init.d/squid stop
10. Masih pada PUTTY, copy-paste perintah di bawah satu-persatu
  • chown proxy:proxy /cache
  • chmod 777 /cache
  • chown proxy:proxy /etc/squid/storeurl.pl
  • chmod 777 /etc/squid/storeurl.pl
  • chmod +x /etc/init.d/squid
  • /etc/init.d/squid stop 
  • squid -f /etc/squid/squid.conf -z 
  • /etc/init.d/squid restart 
11. Reboot PC proxy-nya
12. Setting mikrotiknya:
/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.7.2 \
to-ports=3128 protocol=tcp dst-port=80,8080.3128 \
src-address==!192.168.7.0/24
/ip firewall mangle
add chain=postrouting action=mark-packet \
new-packet-mark=proxy-hit passthrough=no dscp=12 
/queue tree
add name="A_HIT-Proxy" parent=lan packet-mark=proxy-hit limit-at=0 \
queue=default priority=8 max-limit=0 burst-limit=0 \
burst-threshold=0 burst-time=0s  
13. Buka http://www.whatismyip.com/   Jika berhasil, akan keluar keterangan IP kamu dengan proxy internal LUSCA

Selamat mencoba.......

ScreenShot HASILNYA...:

0 komentar:

Post a Comment

 
Toggle Footer