Breaking News
Loading...
14 October 2011

Simulasi Jaringan dengan Virtualbox & Mikrotik

VirtualBox adalah sebuah software untuk menginstal sistem operasi secara virtual. Dengan sifatnya yang virtual berarti virtualbox dapat digunakan sebagai media untuk mengeksplore berbagai macam software baik itu sistem operasi, software-software tertentu dengan platform tertentu, juga bisa digunakan untuk melaksanakan simulasi jaringan tanpa device-device network fisik yang akan menekan biaya eksperimen (alias ngirit).
Sebuah jaringan komputer tidak akan lepas dari interface-interface yang menjadi media komunikasi antar device/host, virtualbox mengakomodasi hal itu dengan menyediakan fasilitas setting interface/adapter jaringan. Ada beberapa tipe adapter jaringan, tipe-tipe tersebut adalah:
  • NAT : Tipe ini akan menyebabkan host virtual dapat melakukan ping ke host nyata dan tidak sebaliknyaBridge.
  • Bridge : Tipe ini menyebabkan semua host baik host virtual maupun host nyata akan bisa saling ping.
  • Internal Network : Tipe ini akan menyebabkan hanya host-host dilingkungan virtual saja yang bisa saling berkomunikasi (ping).
Rencana Simulasi
Desain Topologi Network
Topologi jaringan yang akan digunakan dalam simulasi ini adalah topologi yang sederhana, berikut desainnya:
Kebutuhan Simulasi:
  • PC/Laptop dengan resource yang besar
  • Koneksi internet dengan ISP, kenapa saya menyarankan ISP? Karena dalam percobaan dengan menggunkan mobile broadband/modem tidak bisa membagi koneksi internet lebih dari satu host
  • Mikrotik router Operating System
  • Sebagai client akan dipakai Microsoft Windows XP, Ubuntu dan CentOS3.
Instalasi dan Konfigurasi
Instalasi
  • Install virtualbox dengan mendownload file installernya di http://virtualbox.org, untuk platform Windows instalasi virtualbox seperti menginstall aplikasi lainnya, untuk lingkungan UNIX silakan baca manualnya di website yang sama. Saya asumsikan masalah instalasi virtualbox tidak ada masalah dan telah terinstall dengan baik dikomputer anda.- Install sistem operasi yang akan dipakai sebagai client (Windows XP, Ubuntu dan CentOS), untuk mempermudah instalasi sistem operasi gunakan file image (*.iso). Saya asumsikan masalah instalasi sistem operasi di virtualbox tidak ada masalah dan ketiganya sudah terinstall dengan baik divirtualbox anda.
  • Install Mikrotik router, jika anda tidak mempunyai cukup dana untuk membeli mikrotik untuk sementara gunakan mikrotik yang sudah dicrack, sama seperti instalasi sistem operasi untuk client, instalasi mikrotik juga cukup menggunakan file image (*.iso). Sekali lagi saya asumsikan masalah instalasi mikrotik tidak ada masalah dan mikrotik sudah terinstall divirtualbox anda.
Konfigurasi Network Adapter untuk masing-masing host (mikrotik dan clients) di virtualbox
Mikrotik
Adapter 1 –> enable: yes, type: bridge, device: device jaringan yang sedang terhubung ke internet (wired/wireless)
Adapter 2 –> enable: yes, type: internal network
Komputer Client
Adapter 1 –> enable: yes, type: internal network
Konfigurasi Mikrotik Router
1. Mengubah nama interface (ether)
1[admin@M4jk3m1] > interface set ether1 name=publik
2[admin@M4jk3m1] > interface set ether2 name=lokal
2. Menambahkan ip address masing-masing interface
1[admin@M4jk3m1] > /ip address
2[admin@M4jk3m1 /ip address] > add address=192.168.1.10/24 interface=publik
3[admin@M4jk3m1] /ip address > add address=192.168.20.1/24 interface=lokal
Menambahkan gateway statik
1[admin@M4jk3m1] > ip route add gateway=192.168.1.1
NB: IP 192.168.1.1 adalah ip address dari wireless router, saya menggunakan wireless router Asus RT-N10
Menambahkan DNS
1[admin@M4jk3m1] > ip dns set primary-dns=202.78.108.23
2[admin@M4jk3m1] > ip dns set secondary-dns=192.168.1.1
NB: ip 202.78.108.23 adalah dns yang diberi oleh pihak isp saya, 192.168.1.1 adalah dns lokal dijaringan saya
5. Menambahkan NAT
1[admin@M4jk3m1] > ip firewall nat chain=srcnat action=masquerade src-address=192.168.20.0/24 out-interface=publik
6. Tes koneksi
Ping gateway: 192.168.1.1
Ping ke 8.8.8.8
Jika hasil semua pengetesan ping diatas hasilnya reply berarti konfigurasi mikrotik telah sukses
Konfigurasi Network CentOS
1. Setting ip address statik di eth0
1# nano /etc/sysconfig/network-scripts/ifcfg-eth0
2DEVICE=eth0BOOTPROTO=none
3HWADDR=08:00:27:BE:B0:68 # Generate automatically from your mac address
4IPADDR=192.168.20.2
5NETMASK=255.255.255.0
6NETWORK=192.168.20.0
7BROADCAST=192.168.20.255
8GATEWAY=192.168.1.1
9ONBOOT=yes
2. Menambahkan DNS
1# nano /etc/resolve.conf
2Nameserver 192.168.20.1
3Nameserver 202.78.108.233
Restart service
1# /etc/init.d/network restart
4. Tes koneksi
Ping ke gateway lokal (mikrotik) ping 192.168.20.1
Ping ke gateway publik (mikrtotik) ping 192.168.1.10
Ping ke 8.8.8.8
Jika semua tes diatas reply maka konfigurasi network untuk client di centos berhasil
Konfigurasi Network Ubuntu
1. Setting ip address statik di eth0
01# nano /etc/network/interface
02auto lo
03iface lo inet loopback
04
05auto eth0
06iface eth0 inet static
07address 192.168.20.4
08netmask 255.255.255.0
09gateway 192.168.10.1
10network 192.168.20.0
11broadcast 192.168.20.255
2. Menambahkan DNS
1# nano /etc/resolve.conf
2Nameserver 192.168.20.1
3Nameserver 202.78.108.233
Restart service
1# /etc/init.d/networking restart
4. Tes koneksi
Ping ke gateway lokal (mikrotik) ping 192.168.20.1
Ping ke gateway publik (mikrtotik) ping 192.168.1.10
Ping ke 8.8.8.8
Jika semua tes diatas reply maka konfigurasi network untuk client di Ubuntu berhasil

0 komentar:

Post a Comment

 
Toggle Footer