06 January 2012

Limit Streaming Youtube dengan Layer-7 Mikrotik


Pada kesempatan kali ini, akan membahas mengenai cara membatasi streaming video "youtube" dengan menggunakan layer-7 pada mikrotik.
Sebelum memulai silahkan log in ke router/mikrotik ada dan berikut langkah - langkahnya :
:. Pada menu IP - Firewall - Pilih opsi Layer 7 Protocols. Buat rule baru dengan nama youtube regexp : http/(0\.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][0-9][\x09-\x0d -~]*(content-type: video) , tidak disarankan
menggunakan terminal karena beberapa regexp tidak bisa dijalankan, ada error gtu d. ato boleh dicoba : /ip firewall layer7-protocol add name=youtube regexp="http/(0\.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][0-9][\x09-\x0d -~]*(content-type: video)" 

:. Pindah ke menu Mangle Buat rule baru untuk membaca paket data yang melewati jaringan sesuai layer7 yang dibuat tad, ikuti aja gambar berikut:
 Klik Tab Advance pada opsi Layer 7 Protocol pilih youtube
 Lanjut pilih Tab Action pada action=mark packet, new packet mark=yo-tube, hilangkan centang pada passthrough, dan klik OK.
Command semuanya... : /ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=yo-tube passthrough=no layer7-protocol=yutube
:. Langkah terakhir adalah dengan membuat Simple queue yang akan digunakan untuk membatasi BW yang diberikan. klik Queues dan klik + pada simple queue, name=limit youtube, pada Max Limit isi dengan maximal bw yg di berikan misalnya 64Kbps,
Klik tab advanced pada packet marks pilih yo-tube.
 

Command : /queue simple add name="yu-limit" interface=all parent=none packet-marks=yo-tube direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=512k/512k burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 
Demikian cara singkat namun cepat, bagaimana membatasi streaming youtube pada jaringan mengunakan mikrotik.
Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik)

Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik)

Kita lanjutkan lagi pembahasan untuk tweak mikrotik dari artikel sebelum. Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) Image   Kali ini kita bahas mengenai Streaming yang dibatasi oleh Mikrotik. Kembali ke kasus yang sering terjadi, ” Anda kesalkan kalau ada seseorang yang memutar Streaming membuat Koneksi YouTube anda jadi lambat? atau bukan hanya saat kita membuka Youtube saja yang lambat, ketika kita bermain Game Online seperti Point Blank pun, kita akan merasa sangat terganggu.” Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) Image
Sebenarnya caranya sangat simple, dengan tweaks Mikrotik ini semuanya akan jadi mungkin. Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) Image
Buatlah Rule layer 7 dulu di winbox,  karena penulis coba kalo pake terminal Regexnya dianggap tidak Valid, yang perlu kalian perhatikan adalah isi dari regexp = case sensitive besar kecil typing berpengaruh.
Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) ImageNah.. Saya rasa semua sudah mengerti pemahamannya.
Silahkan Perhatikan ketiga Source Kode dibawah ini :
  1. /ip firewall layer7-protocol
    add name=http-video regexp="http/(0.9|1.0|1.1)[x09-x0d ][1-5][0-9][0-9][x09-x0d -~]*(content-type: video)"
  2. /ip frewall mangle
    add action=mark-packet chain=prerouting comment="http-video mark-packet"
    disabled=no layer7-protocol=http-video new-packet-mark=http-video
    passthrough=no
  3. /queue simple
    add max-limit=0/64000 name=http-video packet-marks=http-video
Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) ImageSekarang ketika kamu membuka YouTube maka akses internetnya akan berubah menjadi limit, begitu juga ketika kamu bermain Game Online. Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) Image
tetapi untuk yang bermain streaming, aksesnya ini hanya dibatasi atau dilimit dengan kecepatan 64 kbps. Membuat YouTube Streaming Menjadi Limit (Tweak Mikrotik) Image
setting limited download unlimited browsing di mikrotik

setting limited download unlimited browsing di mikrotik

Quote:
At the first You have to make 2 rule:

ETHER 1 = PUBLIK (Your ISP)

ETHER 2 = LOCAL

1. Make a Connection Mark
WINBOX > IP > FIREWALL > MANGLE>
[+] ADD NEW
chain = forward
protocol = TCP(6)
in interface = ETHER 1
out interface = ETHER 2
(Go to Advance Tab)
connection bytes = 262146-4294967295 (
(Go to Action Tab)
Action = mark connection
New Connection Mark = Download
Passtrough = [V] <- right sign

2. Make Packet Mark
[+] ADD NEW
chain = forward
protocol = TCP(6)
in interface = ETHER 1
out interface = ETHER 2
Connection Mark = Download
(Go to Action Tab)
Action = mark packet
New Packet Mark = Download

3. Buat Queue Type
WINBOX > QUEUES > QUEUE TYPES
[+] ADD NEW
name = shape
kind = pcq
( Go to Setting Tab)
rate = 256000 <- we make an assumption that 256kB is Download rate
clasifier = dst. Address [v] <– right sign

4. Buat Queue Tree
WINBOX > QUEUES > QUEUE TREE
[+] ADD NEW
name = Download
parent = global out
packet mark = Download
queue type = shape
max limit = 256000

5. Finished
Load Balancing with two interfaces

Load Balancing with two interfaces

Network Diagram

Image:ibgp_load_bal.png

Configuration

On Router A:
# loopback interface /interface bridge add name=lobridge  # addresses /ip address add address=1.1.1.1/24 interface=ether1 /ip address add address=2.2.2.1/24 interface=ether2 /ip address add address=9.9.9.1/32 interface=lobridge  # ECMP route to peer's loopback /ip route add dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2  # BGP /routing bgp instance set default as=65000 /routing bgp add name=peer1 remote-address=9.9.9.2 remote-as=65000 update-source=lobridge 
On Router B:
# loopback interface /interface bridge add name=lobridge  # addresses /ip address add address=1.1.1.2/24 interface=ether1 /ip address add address=2.2.2.2/24 interface=ether2 /ip address add address=9.9.9.2/32 interface=lobridge  # ECMP route to peer's loopback /ip route add dst-address=9.9.9.1/32 gateway=1.1.1.1,2.2.2.1  # BGP /routing bgp instance set default as=65000 /routing bgp add name=peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge  # a route to advertise /routing bgp network add network=4.4.4.0/24 

Results

Check that BGP connection is established:
[admin@B] > /routing bgp peer print status Flags: X - disabled 0   name="peer1" instance=default remote-address=9.9.9.1 remote-as=65000     tcp-md5-key="" nexthop-choice=default multihop=no route-reflect=no hold-time=3m     ttl=255 in-filter="" out-filter="" address-families=ip     update-source=lobridge default-originate=no remote-id=1.1.1.1     local-address=9.9.9.2 uptime=28s prefix-count=0 updates-sent=1     updates-received=0 withdrawn-sent=0 withdrawn-received=0 remote-hold-time=3m     used-hold-time=3m used-keepalive-time=1m refresh-capability=yes     as4-capability=yes state=established 
Route table on Router A:
[admin@A] > /ip route print Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit #      DST-ADDRESS        PREF-SRC        G GATEWAY                 DISTANCE INTER... 0 ADC  1.1.1.0/24         1.1.1.1                                   0        ether1 1 ADC  2.2.2.0/24         2.2.2.1                                   0        ether2 2 ADb  4.4.4.0/24                         r 9.9.9.2                 200      ether1                                                                              ether2 3 ADC  9.9.9.1/32         9.9.9.1                                   0        lobridge 4 A S  9.9.9.2/32                         r 1.1.1.2                 1        ether1                                           r 2.2.2.2                          ether2 
[admin@A] > /ip route print detail Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 0 ADC  dst-address=1.1.1.0/24 pref-src=1.1.1.1 interface=ether1 distance=0 scope=10  1 ADC  dst-address=2.2.2.0/24 pref-src=2.2.2.1 interface=ether2 distance=0 scope=10  2 ADb  dst-address=4.4.4.0/24 gateway=9.9.9.2 interface=ether1,ether2        gateway-state=recursive distance=200 scope=40 target-scope=30        bgp-local-pref=100 bgp-origin=igp received-from=9.9.9.2  3 ADC  dst-address=9.9.9.1/32 pref-src=9.9.9.1 interface=lobridge distance=0 scope=10  4 A S  dst-address=9.9.9.2/32 gateway=1.1.1.2,2.2.2.2 interface=ether1,ether2        gateway-state=reachable,reachable distance=1 scope=30 target-scope=10 
The route 4.4.4.0./24 is installed in Linux kernel now with two nexthops: 1.1.1.2 (on ether1) and 2.2.2.2 (on ether2).

Example with eBGP


Network Diagram

Image:ebgp_load_bal.png

Configuration

Here the example given above is further developed for eBGP case. By default, eBGP peers are required to be directly reachable. If we are using loopback interfaces, they technically are not, so multihop=yes configuration setting must be specified.
On Router A:
/routing bgp instance set default as=65000 /routing bgp set peer1 remote-address=9.9.9.2 remote-as=65001 update-source=lobridge multihop=yes 
On Router B:
/routing bgp instance set default as=65001 /routing bgp set peer1 remote-address=9.9.9.1 remote-as=65000 update-source=lobridge multihop=yes 

Results

If we now print the route table on Router A, we see that the route from Router B is there, but it's not active:
... 2  Db  dst-address=4.4.4.0/24 gateway=9.9.9.2 interface="" gateway-state=unreachable        distance=20 scope=40 target-scope=10 bgp-as-path="65001" bgp-origin=igp        received-from=9.9.9.2 ... 
This is because eBGP routes are installed with lesser target-scope by default. To solve this, setup routing filter that sets larger target-scope:
/routing filter add chain=bgp-in set-target-scope=30 /routing bgp set peer1 in-filter=bgp-in 
Or else, modify scope attribute of the static route:
/ip route set [find dst-address=9.9.9.2/32] scope=10 
Either way, the route to 4.4.4.0/24 should be active now:
2 ADb  dst-address=4.4.4.0/24 gateway=9.9.9.2 interface=ether1,ether2        gateway-state=recursive distance=20 scope=40 target-scope=10        bgp-as-path="65001" bgp-origin=igp received-from=9.9.9.2 

Notes

  • BGP itself as protocol does not supports ECMP routes. When a recursively resolved BGP route is propagated further in the network, only one nexthop can be selected (as described here) and included in the BGP UPDATE message.
set dowloand dan uploand di mikrotik

set dowloand dan uploand di mikrotik

Equal Bandwidth for a Number of Users

Use PCQ type queue when you need to equalize the bandwidth [and set max limit] for a number of users. We will set the 64kbps download and 32kbps upload limits.
PCQ.png
There are two ways how to make this: using mangle and queue trees, or, using simple queues.
1. Mark all packets with packet-mark all:
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=all passthrough=no

2. Setup two PCQ queue types - one for download and one for upload. dst-address is classifier for user's download traffic, src-address for upload traffic:
/queue type add name="PCQ_download" kind=pcq pcq-rate=64000 pcq-classifier=dst-address
/queue type add name="PCQ_upload" kind=pcq pcq-rate=32000 pcq-classifier=src-address

3. Finally, two queue rules are required, one for download and one for upload:
/queue tree add parent=global-in queue=PCQ_download packet-mark=all
/queue tree add parent=global-out queue=PCQ_upload packet-mark=all
If you don't like using mangle and queue trees, you can skip step 1, do step 2, and step 3 would be to create one simple queue as shown here:
/queue simple add queue=PCQ_upload/PCQ_download target-addresses=192.168.0.0/24

Certain Bandwidth Equal Distribution between Users

Unknown Bandwidth Equal Distribution between Users

See Also

Cara Memisahkan Browse, Download, Upload, Dan Game di MIKROTIK

Cara Memisahkan Browse, Download, Upload, Dan Game di MIKROTIK

Settingan ini Berjalan Pada Mikrotik RB750 OS ver.4.5 Dan percobaan Ini dilakukan pada mikrotik PC dengan Mikrotik Versi V2.9.27

Siapkan Perangkat PC dan Instal Mikrotik V2.9.27
  • Lan Card 1 menuju ISP dalam settingan ini menggunakan Speedy "Jaringan Speedy"
  • Lan Card 2 Menuju Jaringan Local dengan nama "Jaringan Local"
  • Setting IP untuk Lan 1 (Baca Tutorial Instal Mikrotik)
  • setting IP untuk Lan 2 (disini IP : 192.168.0.0/24
Settingan Yang akan Dilakukan :
  • GAME Poin Blank
  • Game Poker
  • BROWSING
  • UPLOAD
  • LIMIT DOWNLOAD
  • QUEUE
Tahapan atau teknik setting seperti berikut :

  • Settingan Untuk GAME Poin Blank

contoh buat Point Blank, game lain sesuaikan aja port/ip nya

Untuk Perintah Dibawah buatkan Pada bagian IP-Firewall-Mangle

-------------------------------------------------------------------------------------------------
chain=game action=mark-connection new-connection-mark=Game passthrough=yes protocol=tcp dst-address=203.89.146.0/23 dst-port=39190 comment=”Point Blank”
-------------------------------------------------------------------------------------------------
chain=game action=mark-connection new-connection-mark=Game passthrough=yes protocol=udp dst-address=203.89.146.0/23 dst-port=40000-40010
-------------------------------------------------------------------------------------------------
chain=game action=mark-packet new-packet-mark=Game_pkt passthrough=no connection-mark=Game
-------------------------------------------------------------------------------------------------
chain=prerouting action=jump jump-target=game
-------------------------------------------------------------------------------------------------

  • Settingan Untuk GAME Poker

Untuk Perintah Dibawah buatkan Pada bagian IP-Firewall-Mangle

-------------------------------------------------------------------------------------------------
chain=forward action=mark-connection new-connection-mark=Poker_con passthrough=yes protocol=tcp dst-address-list=LOAD POKER comment=”POKER”

-------------------------------------------------------------------------------------------------
chain=forward action=mark-connection new-connection-mark=Poker_con passthrough=yes protocol=tcp content=statics.poker.static.zynga.com
-------------------------------------------------------------------------------------------------
chain=forward action=mark-packet new-packet-mark=Poker passthrough=no connection-mark=Poker_con
-------------------------------------------------------------------------------------------------

  • BROWSING
-------------------------------------------------------------------------------------------------
chain=forward action=mark-connection new-connection-mark=http passthrough=yes protocol=tcp in-interface=WAN out-interface=Lan packet-mark=!Game_pkt connection-mark=!Game connection-bytes=0-262146 comment=”BROWSE”
-------------------------------------------------------------------------------------------------
chain=forward action=mark-packet new-packet-mark=http_pkt passthrough=no protocol=tcp connection-mark=http
-------------------------------------------------------------------------------------------------
chain=forward action=mark-packet new-packet-mark=http_pkt passthrough=no protocol=tcp connection-mark=http
-------------------------------------------------------------------------------------------------

  • UPLOAD
-------------------------------------------------------------------------------------------------
chain=prerouting action=mark-packet new-packet-mark=Upload passthrough=no protocol=tcp src-address=192.168.0.0/24 in-interface=Lan packet-mark=!icmp_pkt comment=”UPLOAD”
-------------------------------------------------------------------------------------------------

  • LIMIT DOWNLOAD
-------------------------------------------------------------------------------------------------
chain=forward action=mark-connection new-connection-mark=Download passthrough=yes protocol=tcp in-interface=WAN out-interface=Lan packet-mark=!Game_pkt connection-mark=!Poker_con connection bytes=262146-4294967295 comment=”LIMIT DOWNLOAD”
-------------------------------------------------------------------------------------------------
chain=forward action=mark-packet new-packet-mark=Download_pkt passthrough=no packet-mark=!Game_pk> connection-mark=Download
-------------------------------------------------------------------------------------------------

  • QUEUE
Queue Type
-------------------------------------------------------------------------------------------------
name=”Download” kind=pcq pcq-rate=256000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000


name=”Http” kind=pcq pcq-rate=1M pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000

name=”Game” kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=src-address,dst-address,src-port,dst-port pcq-total-limit=2000

name=”Upload” kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=src-address pcq-total-limit=2000
-------------------------------------------------------------------------------------------------

Queue Tree
-------------------------------------------------------------------------------------------------
name=”Main Browse” parent=Lan limit-at=0 priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s

name=”Browse” parent=Main Browse packet-mark=http_pkt limit-at=0 queue=Http priority=8 max-limit=1M burst-limit=0 burst-threshold=0 burst-time=0s

name=”Game” parent=global-total packet-mark=Game_pkt limit-at=0 queue=Game priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

name=”Poker” parent=global-out packet-mark=Poker limit-at=0 queue=Game priority=3 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

name=”Download” parent=global-out packet-mark=Download_pkt limit-at=0 queue=Download priority=8 max-limit=256k burst-limit=0 burst-threshold=0 burst-time=0s

name=”Main Upload” parent=global-in limit-at=0 priority=8 max-limit=256k burst-limit=0 burst-threshold=0 burst-time=0s

name=”Upload” parent=Main Upload packet-mark=Upload limit-at=0 queue=Upload priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

05 January 2012

Translation Widgets for your blog

Memasang translete pada blog sangat perlu karena mungkin saja ada pengunjung dari negara asing yang nyasar keblog anda, tapi yang harus diperhatikan agar tidak terjadi kesalahan translate maka blog anda harus menggunakan bahasa yang resmi, bukan bahasa pasaran atau gaul.
Nah caranya:
  • Seperti biasa sig in dulu ke blogger.
  • Masuk/ klik tombol layout/ tataletak.
  • Klik tombol elemen halaman/ page elemen=>tambah gadget=>HTML/ Java script
  • Beri nama/ isi titel dengan kalimat translate atau dengan kalimat yang anda sukai. Kemudian Copi kode berikut dan paste dikolom HTML/ Java Script.


1. Google Translation Widget








2.Yahoo Babelfish Widget







3.Microsoft Translator Widget







4."Translate This" Button




   on mouseover.......




5.by AllBlogTools







6.TRANSLATE




  • Maka hasilnya seperti dibawah ini:
Google Translate



7.
  • Jika lebar dari sidebar anda tidak mencukupi untuk memuat susunan 2 baris seperti gambar di atas, anda bisa menggantinya dengan susunan 3 baris, seperti gambar di bawah ini:
Google Translate
  • Silahkan anda copy dan pastekan script di bawah ini, jika anda menginginkan susunan 3 baris seperti gambar di atas


  • Seandainyapun susunan 3 baris tidak muat pada sidebar anda, sekarang anda bisa mencoba dengan susunan 4 baris, seperti gambar di bawah ini:
Google Translate
  • Silahkan anda copy dan pastekan script di bawah ini, jika anda menginginkan susunan 4 baris seperti gambar di atas
  • Tekan tombol save/ simpan. Pada elemen halaman save lagi. Tunggu sampai proses berlangsung dan tampil info bahwa setting berhasil disimpan. Liat hasilnya diblog anda.
Semoga bermanfaat!!!

04 January 2012

Cara membuat tab View Modern

Tutorial kali ini kita akan belajar lagi tentang desain template (cieh)? Bagaimana menambahkan elemen halaman atau kolom full widget pada sidebar template blogger dengan menggunakan CSS, XHTML dan JavaScript hanya dalam empat langkah simple, kita juga bisa dengan mudah mengganti warna dan widget langsung pada area dashboard. Berikut sebuah screenshot simple hasil dari tuturial ini:
 
tab view versi 2 image.   
imagetab view versi 2
Tampilannya mirip tab view sederhana yang triknya pembuatannya pernah saya bahas sebelumnya hanya saja selain perbedaan yang sudah saya sebutkan diatas kolom widget ini ketika menu diklik tingginya akan menyesuaikan dengan tinggi widget. Untuk menguji dan meyakinkan sobat. Sekalian saya minta saran dan kritik teman-teman untuk kedua tampilan terbaik template sederhana itu!!!
O ya saya sarankan untuk mengetes tutorial ini pada minima template atau backup template sobat sebelum bereksperimen dengan template sobat saat ini.
Oke sekarang ikuti langkah-langkah berikut:
Cara menambahkan elemen halaman baru atau kolom full widgets pada sidebar template blogger/ Cara membuat tab view versi dua:





  • Loggin ke akun blogger anda, pada dashboard klik layout > edit html dan letakkan script berikut sebelum tag </head>



  • Selanjutnya cari kode berikut <div id='sidebar-wrapper'> just below there add the following code
     
  • Kode diatas hanya untuk tiga tab jika ingin lebih tinggal tambah kode serupa, tapi ingat id tab harus unik tidak boleh sama.

  • Sekarang tambahkan kode CSS berikut diatas ]]></b:skin>
     
  • Dalam kode CSS diatas terdapat 4 variables named tbbxbgcolor, tbbxbrcolor, tbbxcolor1 and tbbxcolor2 jadi kita akan mudah mengganti warna tab konten langsung pada dashboard. Terakhir kita tambahkan code variable berikut pada bagian atas template variable definitions:
    Sekarang simpan template! Klik elemen halaman/ page elemen jika sobat berhasil akan melihat kolom seperti screenshot berikut.
     
    Sobat bisa menambahkan sebuah widget setiap klik nomer yang ada, jadi sobat dapat menambahkan sekian widget pada 1 kolom dengan mudah. Jangan lupa setelah melihat preview/ pratinjau blog untuk menyimpan atau save template.
    Untuk mengganti warna tab menu, background atau border masuk pada menu layout (tata letak) klik tab font dan warna seperti screenshot berikut.
     


    SUMBER:http://www.ipanrock.info/2011/05/cara-membuat-tab-view-modern.html#more

  • Cara Upgrade Windows Xp Sp2 Ke Sp3 tanpa Install Ulang

    Cara Upgrade Windows Xp Sp2 Ke Sp3 tanpa Install Ulang.
    ini sangat mudah dilakukan dan simple sekali tidak perlu waktu yang lama dan tidak perlu install ulang sehingga file yang ada di harddisk C tidak terformat..
    Cara Upgrade Windows Xp Sp2 Ke Sp3 tanpa Install Ulang. ini mungkin hanya bisa dilakukan pada windows xp sp2 ke sp3. soalnya saya hanya mencoba pada windows xp sp2 ke sp3 saja. dan belum saya coba pada windows xp sp1.
    anda bisa mengikuti tutorial  Cara Upgrade Windows Xp Sp2 Ke Sp3 tanpa Install Ulang.  berikut ini jika ingin upgrade windows xp anda ke sp3
    1.pertama buka registry editor(regedit)

    2. Jika Sudah Terbuka Registry Editor,Maka langka selanjutnya yang harus anda lakukan adalah
    Masuk Ke "HKEY_LOCAl_MACHINE-SYSTEM-ControlSet002-Control-Windows"

    3.selanjutnya anda klik 2X CSDVersion Ubah Nilai 200 menjadi 300 sepeti gambar berikut
    4. selesai restart komputer anda
     Note:
    Ganti Juga Yang Di  HKEY_LOCAl_MACHINE-SYSTEM-ControlSet001-Control-Windows
    jika anda belum percaya coba install software yang hanya bisa diinstall di windows xp sp3
    dan tidak bisa dinstall di windows xp sp2 seperti microsoft office 2010
    sekian tutorial Cara Upgrade Windows Xp Sp2 Ke Sp3 tanpa Install Ulang. kali ini.
                                                           "semoga bermanfaat"

    jika ada pertanyaan mengenai artikel Cara Upgrade Windows Xp Sp2 Ke Sp3 tanpa Install Ulang. silahkan isi form komentar dibawah ini...

    sumber: http://www.ipanrock.info/2011/07/cara-upgrade-windows-xp-sp2-ke-sp3.html#more
    Cara Format Harddisk Hanya Menggunakan NotePad

    Cara Format Harddisk Hanya Menggunakan NotePad

    Jika Anda berpikir notepad tidak berguna maka anda salah karena anda dapat melakukan banyak hal dengan notepad yang dapat kita tidak pernah imagined.di tutorial hack ini saya akan menunjukkan cara untuk memformat HDD menggunakan notepad. Ini benar-benar keren.
    caranya sangat mudah sekali silahkan anda ikuti tutorial dibawah ini dengan teliti :

    Langkah 1.
    copy kode berikut  Pada Notepad Persis seperti ini
    01001011000111110010010101010101010000011111100000


    Langkah 2.
    Simpan Sebagai EXE Nama terserah anda
    contoh: ipanrock.exe

    Langkah 3.
    save file as type pilih all files

    ATAU 

    Format PC Anda Menggunakan NotePad - JIKA kamu pikir bisa tidak format drive C ketika windows berjalan tentu saja bisa. ada beberapa cara lebih sehingga dapat menguji pada drive lain ini adalah kode biner sederhana

    format c:\ /Q/X — Ini akan format drive c:\

    01100110011011110111001001101101011000010111010000 100000011000110011101001011100
    0010000000101111010100010010111101011000



    format d: \ / Q / X - ini akan format drive d: \

    01100110011011110111001001101101011000010111010000 100000011001000011101001011100
    001000000010111101010001001011110101100



    format a: \ / Q / X - ini akan format drive a:\

    01100110011011110111001001101101011000010111010000 100000011000010011101001011100
    0010000000101111010100010010111101011000



    del / F / S / Q c: \ boot.ini - ini akan menyebabkan komputer anda tidak booting.

    01100100011001010110110000100000001011110100011000 101111010100110010111101010001
    00100000011000110011101001011100011000100110111101 101111011101000010111001101001
    0110111001101001

    Format PC Anda Menggunakan NotePad - Jangan mencoba pada PC Anda. Jangan main-main ini adalah  hanya  untuk tujuan pendidikan masih jika Anda masih tidak bisa coba ini 
    buka ke notepad dan ketik berikut ini: 

    @ Echo off
    Del C: \ *.* | y

    menyimpannya sebagai Dell.bat

    ingin lebih buruk kemudian ketik berikut:

    @ Echo off
    del%% \ SystemDrive *.* / f / s / q
    shutdown-r-f-t 00

    dan menyimpannya sebagai file. bat


    sumber:http://www.ipanrock.info/2011/03/format-pc-anda-menggunakan-notepad.html#more

    03 January 2012

    Memasang Widget Tab View Pada Blog

    Beberapa waktu yang lalu ada yang menanyakan kepada saya bagaimana cara untuk membuat menu tab view seperti pada blog ini. Tetapi karena penjelasannya lumayan rumit jadinya sampai sekarang baru sempat saya posting.

    Nah bagi anda yang belum tahu apa itu tab view. Tab view adalah sebuah widget yang mempunyai fungi tab dimana setiap tab bisa mewakili satu widget atau konten sehingga bisa menghemat ruangan pada blog anda. Contoh tampilannya seperti gambar dibawah ini.

    Ok tanpa panjang lebar bagi anda yang tertarik untuk memasang widget tab view ini di blog anda, silahkan ikuti langkah-langkah dibawah ini:

    1. Login ke Blogger
    2. Pilih Design -> Page Element
    3. Klik Add a Gadget -> HTML/Javascript lalu masukkan kode dibawah ini kedalam kotak

    <style type="text/css">
    div.TabView div.Tabs a
    {
    float: left;
    display: block;
    width: 80px; /* Lebar Kotak Tab */
    height: 22px; /* Tinggi Menu Utama Atas */
    text-align: center; /* Posisi Teks Menu Tab */
    margin: 5px 0px 0px 3px; /* Posisi Kotak Tab */
    background-color: #000; /* Warna background Kotak Tab */
    padding-top: 2px; /* Spasi Atas */
    border: 1px solid #ffffff; /* Warna border kotak Tab */
    border-bottom: 1px solid #ccc; /*Warna border bawah kotak tab */
    font-family: "Arial, Helvetica, sans-serif", Arial; /* Font Kotak Tab */
    font-weight: 900; /* Ketebalan Teks kotak tab */

    }
    div.TabView div.Tabs a:hover, div.TabView div.Tabs a.Active
    {
    background-color: #736F6E; /* Warna background utama kotak tab */ }
    div.TabView div.Pages
    {
    clear: both;
    border: 1px solid #cccccc; /* Warna border Kotak Konten */
    overflow: hidden;
    background-color: #ffffff; /* Warna background Kotak konten */
    }
    div.TabView div.Pages div.Page
    {
    height: 100%;
    padding: 5px; /* Jarak teks dalam kotak content */
    overflow: hidden;
    }
    div.TabView div.Pages div.Page div.Pad
    {
    padding: 3px 5px;
    }

    </style>

    <form action="tabview.html" method="get">
    <div id="TabView" class="TabView">
    <div style="width: 385px;" class="Tabs">
    <a><span style="color: #ffffff">Tab 1</span></a>
    <a><span style="color: #ffffff">Tab 2</span></a>
    <a><span style="color: #ffffff">Tab 3</span></a>
    </div>
    <div style="width: 300px; height: 180px;" class="Pages">

    <div class="Page">
    <div class="Pad">
    konten 1
    </div>
    </div>

    <div class="Page">
    <div class="Pad">
    konten 2
    </div>
    </div>

    <div class="Page">
    <div class="Pad">
    konten 3
    </div>
    </div>
    </div></div></form>

    <script style="text/javascript" src="http://hermanblog.googlecode.com/files/tab_view.js"></script>
    <script type="text/javascript">tabview_initialize('TabView');
    </script>
    Keterangan:
    Tulisan berwarna merah merupakan keterangan dari masing-masing kode. Silahkan atur nilainya sesuai keinginan
    Tulisan berwarna orange merupakan warna judul Tab
    Tulisan berwarna hijau merupakan judul Tab
    Angka 300 pada 'Width' menunjukkan panjang kotak dan 180 pada 'height' menunjukkan tinggi kota. Silahkan ganti nilainya sesuai ukuran template anda.
    Tulisan yang dicetak tebal merupakan isi tab view. Silahkan ganti dengan teks, link, banner atau widget anda.

    4. Kalau sudah, klik Save. Selesai

    Jika anda ingin menambah menu tab baru cukup tambahkan kode yang berkedip dibawahnya.

    Selamat mencoba. Semoga berhasil..

    sumber: http://www.hermanblog.com/2009/04/menambahkan-widget-tab-view-pada-blog.html
    Update status facebook  keren dan unik seperti via BlackBerry

    Update status facebook keren dan unik seperti via BlackBerry

    di sini saya ingin memberikan trik keren ntuk update status di facebook
    cara nya:   1.klik kanan tulisan blackbery
           2.trus klik news tab
                     3.ikuti petunjuk nya

     anda tunggal pilih mau update status pakai BB atau yang lain nya cukup
     banyak pilihan di bawah ini
                        SELAMAT
    ANDA MENJADI ORANG SOMBONG
        update status via BlackBerry
      wkwkwkwkw


    Add Yahoo smileys/emoticons above Blogger comments form

    With this simple hack, your blog readers are now able to use Yahoo smileys/emoticons when they comment on any of your blog posts. I am sure that your readers will really get excited and enjoy using these Yahoo! smileys. This hack will only work if you've enabled embedded comment form feature for your blog.

    This is how it will look above comments form.



    Follow these steps below to install this feature to your blog's template. Always remember to save a copy of your template before start editing your template. At Layout > Edit HTML page, click on the "Expand Widgets Template" and find for thses c+odes below using CTRL+F.


    And you will now see a set of codes as shown below



    Replace them with the codes shown in the box below.


    Now move on with the next step. Find the tag </body>

    and paste this script below before that tag.



    And click save.

    Although, the link in blue colour will work, due to the bandwidth problem I recommend you to upload the Javascript file to your own server. You can download the Smiley.js file here. Once you've uploaded the file, change the above url with your own link. 

    sumber: http://introblogger.blogspot.com/2010/01/add-yahoo-smileysemoticons-above.html#more

    Cara Pasang Random Posts Di Blog

    Pasang Random Posts – Memasang random posts di blog memiliki manfaat bagi blog yang ingin memberikan kesan dinamis kepada para pengunjungnya. Hal ini bisa terjadi karena pemasangan fitur random posts di blog akan memunculkan beberapa judul artikel blog secara acak sehingga mampu membuat pembaca kita menjadi tidak bosan dengan tampilan yang monoton. Selain itu, random posts juga mampu untuk mempromosikan artikel blog kita yang sudah lama diterbitkan untuk bisa dibaca kembali oleh para pengunjung kita.



    Pada pemasangan random posts di blog ini kita bisa melakukan modifikasi tampilan menjadi dua bagian, yaitu pemasangan random posts yang hanya menampilkan judulnya saja dan random posts yang menampilkan judul beserta ikhtisar atau ringkasan isi artikel tersebut. Pemasangannya pun sangat mudah karena kita tidak perlu melakukan editing HTML template. Kita hanya perlu memasukan kode yang diperlukan pada fitur add gadget kemudian menempatkannya pada HTML/JavaScript.

    Adapun cara untuk pasang random posts di blog adalah sebagai berikut:

    Masuk pada akun blogger kita masing-masing.

    Klik rancangan.

    Klik add gadget atau tambah gadget.

    Pilih HTML/JavaScript.

    Masukan kode berikut.

    Random posts hanya menampilkan judul.

    <script type="text/javascript">
    var randarray = new Array();var l=0;var flag;
    var numofpost=4;function randomposts(json){
    var total = parseInt(json.feed.openSearch$totalResults.$t,10);
    for(i=0;i < numofpost;){flag=0;randarray.length=numofpost;l=Math.floor(Math.random()*total);for(j in randarray){if(l==randarray[j]){ flag=1;}}
    if(flag==0&&l!=0){randarray[i++]=l;}}document.write('<ul>');
    for(n in randarray){ var p=randarray[n];var entry=json.feed.entry[p-1];
    for(k=0; k < entry.link.length; k++){if(entry.link[k].rel=='alternate'){var item = "<li>" + "<a href=" + entry.link[k].href + ">" + entry.title.$t + "</a> </li>";
    document.write(item);}}
    }document.write('</ul>');}
    </script>
    <script src="/feeds/posts/default?alt=json-in-script&start-index=1&max-results=1000&callback=randomposts" type="text/javascript"></script>

    Random post menampilkan judul dan ikhtisar.

    <script type="text/javascript">
    var randarray = new Array();var l=0;var flag;
    var numofpost=4;var wordnumber=10;</script>
    <script style="text/javascript" src="http://panduanbelajarblog.googlecode.com/files/random-posts-with-summary.js">
    </script>
    <script src="/feeds/posts/default?alt=json-in-script&start-index=1&max-results=1000&callback=randomposts" type="text/javascript"></script>

    Klik simpan dan selesai.

    Keterangan:

    1. Angka pada var numofpost menunjukan jumlah postingan yang akan ditampilkan pada random posts di blog kita. Gantilah sesuai selera kita masing-masing.
    2. Angka pada wordnumber menunjukan jumlah kata yang akan ditampilkan sebagai ikhtisar yang muncul dalam random posts di blog kita. Gantilah sesuai selera kita masing-masing.


    Pemasangan random posts di blog ini tidak akan banyak berpengaruh pada kecepatan loading blog karena tidak menggunakan widget yang membutuhkan request data dari pihak ketiga atau server lain kecuali pada pemasangan random post yang menampilkan judul beserta ikhtisarnya. Meskipun demikian, hal ini tidak akan terlalu berpengaruh banyak kepada blogspot karena file javascript yang digunakan untuk menampilkan random posts diupload di Google Code yang notabene merupakan tempat upload file secara gratis milik Google yang juga sudah terintegrasi dengan blogspot sesama layanan Google, sehingga upload javascript di Google code ini membuat request datanya relatif cepat dibandingkan server lainnya.


    sumber:http://www.panduanbelajarblog.com/2011/12/pasang-random-posts.html

    02 January 2012

    Load Balance 2 ISP -Policy Routing based on Client IP Address

    Load Balance 2 ISP -Policy Routing based on Client IP Address


    Waktu itu kalo g salah pernah ada di salah satu thread tapi g ada tuts-nya makanya sekarang mau nyumbang dulu....

    ISP 1 : 10.0.128.13
    ISP 2 : 202.6.238.253

    Mari kita berandaikan jika jaringan kamu memiliki IP Address seperti ini :
    Game : 192.178.40.0/26
    Internet : 192.178.40.32/26
    Router : 192.178.40.125/25

    lalu, kita perlu menyeting mangle...
    /ip fi ma add chain=prerouting src-address=192.178.40.0/26 action=mark-routing new-routing-mark=Game comment=Game
    /ip fi ma add chain=prerouting src-address=192.178.40.32/26 action=mark-routing new-routing-mark=Internet comment=Internet

    kemudian, menuju ke Route...
    /ip ro add gateway=10.0.128.13 mark=Game
    /ip ro add gateway=202.6.238.153 mark=Internet

    Jangan melupakan NAT Masquerade yah
    /ip na add chain=srcnat src-address=192.178.40.0/25 action=masquerade

    Silahkan di coba di komputer client "Game" apakah sudah masuk ke jalur ISP 1 dan client "Internet" apakah sudah masuk ke jalur ISP 2



    Waktu itu kalo g salah pernah ada di salah satu thread tapi g ada tuts-nya makanya sekarang mau nyumbang dulu....

    ISP 1 : 10.0.128.13
    ISP 2 : 202.6.238.253

    Mari kita berandaikan jika jaringan kamu memiliki IP Address seperti ini :
    Game : 192.178.40.0/26
    Internet : 192.178.40.32/26
    Router : 192.178.40.125/25

    lalu, kita perlu menyeting mangle...
    /ip fi ma add chain=prerouting src-address=192.178.40.0/26 action=mark-routing new-routing-mark=Game comment=Game
    /ip fi ma add chain=prerouting src-address=192.178.40.32/26 action=mark-routing new-routing-mark=Internet comment=Internet

    kemudian, menuju ke Route...
    /ip ro add gateway=10.0.128.13 mark=Game
    /ip ro add gateway=202.6.238.153 mark=Internet

    Jangan melupakan NAT Masquerade yah
    /ip na add chain=srcnat src-address=192.178.40.0/25 action=masquerade

    Silahkan di coba di komputer client "Game" apakah sudah masuk ke jalur ISP 1 dan client "Internet" apakah sudah masuk ke jalur ISP 2
    yup benar kalo untuk 1 network client oke lah...

    tp gmn kalo kita punya banyak client yang berbeda networknya (dalam 1 ethernet & 1 hub), ex:

    192.168.0.xxx
    192.168.1.xx
    dst...

    gw da mslh ni, rule spt itu gw terapkan di Inet gw. gw dpt 2 koneksi, Wlan + Vsat.

    Di lokal gw ada bbrp client yg berbeda network.

    webserver lokal yg gw direct jg ga jalan coz di ping aja ga bs.

    Begitu juga dengan Radmin. smua ga fungsi...

    Ada solusi??




     Loh?? gampang!! tinggal di masquerade sama tambah rule lagi... misal gini

    Network Pertama
    Game : 192.178.40.0/26
    Internet : 192.178.40.32/26
    Router : 192.178.40.125/25


    Code:
    /ip fi ma add chain=prerouting src-address=192.178.40.0/26 action=mark-routing new-routing-mark=Game comment=Game
    /ip fi ma add chain=prerouting src-address=192.178.40.32/26 action=mark-routing new-routing-mark=Internet comment=Internet
    
    /ip na add chain=srcnat src-address=192.178.40.0/25 action=masquerade
    Network Kedua
    Internet : 192.168.30.0/26
    Router : 192.168.30.125/25
    Code:
    /ip fi ma add chain=prerouting src-address=192.168.30.0/26 action=mark-routing new-routing-mark=Internet comment=Internet
    
    /ip na add chain=srcnat src-address=192.178.30.0/25 action=masquerade
    Jadi yang penting adalah PENGETAHUAN TENTANG SUBNET jika belum tahu silahkan belajar dahulu, karena ini adalah pembagian alokasi IP pada client basis sama subnet.